Linux: работа с vpn, туннелями (gre, ipsec, stunnel, etc)

Зачем одному пользователю
  • Сбор информации за вами
  • Telegram
реализации

Их очень много, выбираем что нравится:

  • xSwan (StrongSwan, LibreSwan) и реализации на основе них (напр. ipsec-vpn-server ниже)
  • SoftEther
  • Racoon
  • Accel-ppp (bras средне-провайдерского/энтерпрайз уровня)
  • RouterOS, pfSense
  • Juniper vSRX, PaloAlto, Fortigate, Checkpoint, Cisco, Sophos XG Firewall, etc.


Читать дальше

iOS заметки

Настройка автоподключения к VPN

Используя L2TP сервер (напр. docker ipsec-vpn-server) можно настроить устройства на iOS с опцией автоподключения к сети при разрыве с любых сетей, используя функционал “VPN On Demand”.

Читать дальше

Network: эволюция производительности сетевых устройств и трансиверов



Читать дальше

SAN на базе IP

Конспект вебинара HonorCup E=DC2 для сдачи HCNA Storage.

IP SAN – способ построения сети хранения поверх транспортной сети TCP/IP (на L2 может быть Ethernet или даже Wi-Fi). Для реализации IP SAN чаще всего используется протокол iSCSI. SCSI – де факто отраслевой стандарт передачи данных между приложением и СХД, а iSCSI (internet SCSI) позволил использовать его в IP сетях.

Читать дальше

Основы облачных технологий и виртуализации

Конспект вебинара HonorCup E=DC2 для сдачи HCNA Cloud.

Описание терминов облачных вычислений можно посмотреть в документе NIST 800-145.

О облачных архитектурах можно почитать в документе NIST 500-292.

Облака:

  • Теорию можно посмотреть тут
  • Решения Huawei по организации облаков на базе их продуктов тут
  • Есть так же хороший конспект на git
  • Почитать про вопросы облачной безопасности тут
  • Вопросы/ответы на HCNA Cloud экзамен тут
  • Moody говорит о том, что облака стали еще более популярны в условиях пандемии коронавируса.


Читать дальше

Настройка WLC Huawei AC6005

Настройка подробно с примерами расписана в доках hdx к контроллерам, тут выдержка конфига для софта до V200R006 с комментами. Протестировать настройку можно в eNSP. Главное после настройки перезагрузить эмулятор – может не анонсить SSID до перезагрузки.

# Licence может понадобиться
license active accept agreement
license function data
license function ac
# DHCP
vlan batch 10 555
# Вариант1 - Глобально
# for AP
dhcp enable
ip pool ap
 network 10.0.0.0 mask 255.255.255.0
 gateway-list 10.0.0.111
 dns-list 8.8.8.8
 option 43 sub-option 3 ascii 10.0.0.111
interface vlan 10
 ip address 10.0.0.111 24
 dhcp select global
# for CLIENTS
ip pool clients
 network 192.168.1.0 mask 255.255.255.0
 gateway-list 192.168.1.1
 dns-list 8.8.8.8
interface vlan 555
 ip address 192.168.1.1 24
 dhcp select global
# Вариант2 - На интерфейсах
interface Vlanif10
 ip address 10.0.0.0 255.255.255.0
 dhcp select interface
 dhcp server option 43 sub-option 3 ascii 10.1.201.100 # контроллер не обязательно должен быть в одной подсети с точками, главное чтобы точкам по option 43 приходил правильный IP контроллера и он был доступен им по L3
interface Vlanif555
 ip address 192.168.1.0 255.255.255.0
 dhcp select interface
 dhcp server dns-list 8.8.8.8
# untagged mgmt vlan, tagged client to AP
interface GigabitEthernet0/0/1
 port link-type trunk
 port trunk pvid vlan 10
 port trunk allow-pass vlan 10 555
# Клиентский интерфейс (не может быть tagged)
interface Wlan-Ess0
 port hybrid pvid vlan 555
 port hybrid untagged vlan 555
# Привязываем точки, поднимается CAPWAP (указываем интерфейс на котором включается CAPWAP)
wlan
 wlan ac source interface vlanif 10
 ap-auth-mode no-auth # после этого точки в конфиге сами появятся и CAPWAP поднимется (на точках CAPWAP UP!!)


Читать дальше

Протокол ERPS как замена STP

  • Пример настройки ERPS
  • ERPS CCM (Continuity Check Message) выполняет задачу обнаружения сбоя L2 канала при наличии линка.
  • ERPS есть на Cisco

 

ERPS – Ethernet Ring Protection Switching – успешно заменяет STP в ряде кейсов.

Особенности протокола:

  • Быстрая сходимость
  • Разные реализации у вендоров т.к.


Читать дальше